phpmyadmin出现”配置文件现在需要一个短语密码”

phpmyadmin出现”配置文件现在需要一个短语密码”问题,可以按下面方法解决:

1、用编辑器打开目录phpmyadmin/libraries中的config.default.php文件

2、查找下面这行:$cfg[‘blowfish_secret’] = ‘这里就是需要的短语密码’;(短语密码请随意填写)

会出现这个问题,是在配置phpmyadmin填写认证方法时,即下面这行:

$cfg[‘Servers’][$i][‘auth_type’] = ‘cookie’;

在此有四种模式可供选择,cookie,http,HTTP,config

config方式即输入phpmyadmin的访问网址即可直接进入,无需输入用户名和密码,是不安全的,不推荐使用。

当该项设置为cookie,http或HTTP时,登录phpmyadmin需要数据用户名和密码进行验证,,具体如下:

PHP安装模式为Apache,可以使用http和cookie;

PHP安装模式为CGI,可以使用cookie

» 链接地址:http://wubangtu.com/571 »英雄不问来路,转载请注明出处。

phpmyadmin出现”配置文件现在需要一个短语密码”》上有 2 条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注